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Rapid Geotechnical Reporting

Software License Agreement and Limited Warranty
This License Agreement is made and entered into by and between GAEA Technologies Ltd. having an office
at 87 Garden Street, Whitby, Ontario, Canada, L1N 9E7 (the "Distributor") and the Licensee, with reference
to the following terms and conditions:

A. The Distributor has the legal right to distribute software and documentation currently
called "Rapid Geotechnical Reporting” (the "Licensed Product").

B. The Licensee now desires to license the use of the Licensed Products.

NOW THEREFORE, the parties agree as follows:

License

Distributor grants, and the Licensee hereby accepts, the nonexclusive license to use the Licensed Product sub-
ject to the terms and conditions contained in this agreement.

Licensee May

1. Unless otherwise agreed in writing, use the Licensed Product on any single computer system at the
licensed facility.
2. Transfer the Licensed Product from one location to another so long as it is not installed simultaneously
on more than one computer.

Licensee May Not

1. Make copies of the Licensed Product.
2. Make copies of the software documentation.
3. Unless otherwise agreed in writing, install and use the software onto more than one computer at a time.
4. Alter, decompile, disassemble, or reverse engineer the Licensed Product.
5. Remove, alter, or obscure the copyright notices.

Term

This License Agreement is effective from the date of purchase by the Licensee of the Licensed Product and
shall remain in force until terminated. The Licensee's rights to use the Licensed Product will terminate if the
Licensee fails to comply with any of the terms or conditions of this License Agreement. Upon such termina-
tion, the Licensee shall return the Licensed Product to the Distributor immediately.
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Limited Warranty

If the Licensee finds a Licensed Product diskette to be defective in materials or workmanship (which shall not
include problems relating to the nature or operation of the Licensed Product) under normal use, the Distributor
will replace it free of charge within one year following the date of purchase. Any request for replacement of
a defective diskette must be accompanied by the original defective diskette and a copy of the original in.

The Licensed Product is provided "as is" without warranty of any kind, either expressed or implied, includ-
ing but not limited to the implied warranties of merchantability and fitness for a particular purpose. The
Distributor does not warrant that the functions contained in the program will meet your requirements or that
the operation of the program will be uninterrupted or error free.  Neither the Distributor nor anyone else who
has been involved in the creation or production of this product shall be liable for any direct, indirect, inci-
dental, special, or consequential damages, whether arising out of the use or inability to use the product, or any
breach of a warranty, and the Distributor shall have no responsibility except to replace the Licensed Product
pursuant to this limited warranty.

General

1. The laws of the Province of Ontario, Canada, shall govern the validity, interpretation and performance of
this License Agreement.
2. If any provision of this License Agreement is determined to be invalid under any applicable statute of rule
of law, it shall be deemed omitted and the remaining provisions shall continue in full force and effect. 
3. The entire agreement between the Distributor and the Licensee is embodied in this Agreement.
4. Any modifications of this License Agreement shall be void unless appearing in writing signed by duly
authorized 
representatives of the License and the Distributor.
5. This License Agreement shall be binding upon and shall inure to the benefit of each party hereto and its
successors and assigns except that any assignment of this License Agreement by the Licensee without the writ-
ten consent of the Distributor shall be void.
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1.0 Getting Started

The Rapid Geotechnical Reporting program is used to collect answers to pre-designed questions in
a template. These answers are then merged  and a standard report is generated in Microsoft Word.
The merging process allows the user to insert different responses and paragraphs into the report
depending upon how a question is answered.

1.1 Program Benefits and Uses

Rapid Geotechnical Reporting has been designed to minimize the amount of time required to gen-
erate standard geotechnical engineering reports and to maximize the flexibility of the final report.
A variety of reports can be created, the program currently comes with templates for conventional
shallow and deep foundations. More templates are always being added and we welcome your sug-
gestions.

Features of the program include:

- Reports can be generated to follow any standard. 
- In addition to your answers to the template, photos can also be added to the final report. 
- The answers to questions are tracked, and a list of unanswered questions can be displayed. 
- Microsoft Access database management system. 
- Network compatible and able to track projects over a network.
- Master project database tracks projects over a network. 
- Report templates are created and edited in Microsoft Word. 
- There can be an unlimited number of reports and projects. 
- Text macros can be created on the desktop and used to rapidly enter common text answers
- Merged report can be immediately opened in Word.  

1.2 Methodology and Data Flow

The program has been designed to minimize the amount of time required to generate a standard
report and to maximize the flexibility of the final report. To accomplish this, the process has been
divided into two steps. 

1.2.1 Enter Report Data

The reports to be generated are grouped into projects. Projects typically contain associated geot-
echnical reports. The data for a report is collected by answering each of the questions in the tem-
plate. The form used and allowable answers for the question are specified  when the template is
created. 

Rapid Geotechnical Reporting User’s Guide Page  11

About Rapid Geotechnical Reporting



1.2.2 Merge Report Data with the Report Template

The final step is to create a final report by merging the data with the report template. During the
merging process the keywords in the report template are replaced by the text associated with each
of the answers to the questions. After the report data has been merged a final report will be creat-
ed in Microsoft Word format. This report can then be edited in Word.

1.3 System Requirements

Below are the software and hardware requirements for the program. 

1.3.1 Software Requirements

· Microsoft Windows 2000 or XP
· Microsoft Word 97 or higher 

1.3.2 Hardware Requirements

· minimum of 128 MB of memory
· CD-ROM drive.

1.4 Installation

To get Rapid Geotechnical Reporting up and running, install the program either from the CD-ROM
or download the install program from GAEA’s web site. For example, to install the CD-ROM from
drive D:

1. Start Windows
2. Insert the CD-ROM into drive D;
3. Choose Start and then Run and type “D:\Rapid Geotechnical Reporting\setup.exe”, or double-
click on “D:\Rapid Geotechnical Reporting\setup.exe” in Windows Explorer, or double-click on
the Add/Remove Programs icon in the Control;
4. Enter the requested information in the installation forms.

On some computer systems, depending on how they are configured, inserting the CD-ROM into
the drive will automatically start the GAEA menu program. In this case select Rapid Geotechnical
Reporting from the menu screen. 
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All of the programs listed on the menu screen can be installed and will run in demo mode until an
unlock code is provided.

1.5 Registering Rapid Geotechnical Reporting

Before Rapid Geotechnical Reporting can be used it must be registered. Prior to the registration
process the program will run in Demo mode. During the registration the program will be unlocked. 

To register the program on the desktop and obtain an unlock code, run the program and press the
Register button. The Registration form shown below will be displayed. In the middle of this form
a unique serial number will be displayed. This serial number is unique for each computer. 

If your computer is connected to the Internet, you can obtain the unlock code by clicking on the
Obtain Unlock Code button. After the button is pressed a registration form on GAEA’s web site
will be displayed on your internet browser. Fill out the form and then click on the submit button.
After your registration information has been received an unlock code will be emailed to you.

If your computer is not connected to the Internet, you can call or fax us the serial number.

After GAEA has received your unique serial number, an unlock code will be generated and
emailed or faxed to you. When you receive the unlock code enter it in the space at the bottom of
the Registration form and then press the Store Unlock Code button. 
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1.6 Transferring the Registration

After the program has been registered, the unlocked program can be transferred to a different com-
puter using the Transfer utility. This utility allows you to move the Rapid Geotechnical Reporting
program between computers without requiring assistance from GAEA. After the registration has
been transferred the program will only run on the new computer. 

Step 1. The first step is to obtain the unique serial number of the new computer. Install and run
Rapid Geotechnical Reporting program on the new computer. Initially the program will start in
Demo mode and the Demo form will be displayed. Press the Register button and write down the
unique serial number for the new computer. 

Step 2. In the second step the Transfer utility is used to generate an unlock code for the new com-
puter. Start Rapid Geotechnical Reporting program on the old PC and select the Transfer menu item
from the Help menu. The Transfer Registration form on the next page will be displayed. Enter the
serial number of the new computer and then press the Transfer Registration button. An unlock code
for the new computer will be displayed. Enter this unlock code in the Registration form on the new
computer, and then press the Store Unlock Code button.
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Report Data
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2.0 Report Data

All the report data is organized into projects. You can have an unlimited number of projects and
each project can contain an unlimited number of reports.

Before the data for a report can be entered, either a new project must be created or an existing proj-
ect opened. The created or opened project is then referred to as the current project. After the proj-
ect has been opened, the new report can be created. Existing reports can be edited by first opening
the project and then the report. 

2.1 Creating a New Project

To create a project select the New Project menu item from the File menu or click on the New
Project button on the toolbar. A New Project form will be displayed where you can enter the

name of the project (up to 100 characters)and the directory to store the project. The project name
must be unique. To assist the entry of a unique name a list of all of the existing projects is displayed.
The  project directory can be on either a local drive or a network drive.

After the name has been specified click on the Ok button to create the project.
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2.2 Opening a Project

To open an existing project click on the Open Project button on the toolbar or select the Open
Project menu item from the File menu. Then select the project on the Open Project form

When the project is opened a list of existing reports in the project will be displayed. After a proj-
ect has been opened it can be closed by selecting the Close Project menu item from the File menu.

The directory path for the project can also be changed on this form by selecting the project and then
clicking on the Path button. A new path for the project can then be selected. This is useful if the
project has been moved.

2.3 Deleting a Project

A project can be deleted using the Open Project Form above. First select the project and then click
on the Delete button.
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2.4 Creating a Report

To create a new report make sure that a project has been opened and then select the New
menu item from the File menu or click on the New button on the Report toolbar. A New

Report form will be displayed where you can enter a unique name for the report (up to 100 char-
acters) and select the Questionnaire to use for the report. The questionnaire will determine the
questions and type of report. 

After the report has been created a menu tree will be displayed showing the sections, subsections,
and questions of the template. The report data can then be entered by selecting a question from the
menu tree. 

If the New menu item is not available make sure that a project is currently opened..
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2.5 Opening a Report

To open an existing report, first open the project containing the report and then select it from
the list of reports on the Project Form or by clicking on the Open Report button on the Report

Toolbar. The list is displayed on the left side of the Project Form and a report can be selected by
double clicking on it.

When the report is opened a menu tree will be displayed showing the sections, subsections, and
questions specified in the template used for the report. The report data can be entered by selecting
a question from the menu tree. After a report has been opened it can be closed by clicking on the
Close button.
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2.6 Entering Report Data

After a report has been created or opened, a report form will be displayed with three tabs. On the
Index tab a menu tree will be displayed showing the sections, subsections, and questions specified
in the template used for the report.

Sections in the menu tree can be expanded and collapsed by double clicking on the section name.
When the section is collapsed only the section is displayed and the subsections are hidden. When
the section is expanded all of the subsections are displayed below the section.

Subsections can contain one or more questions and can be expanded or collapsed by double click-
ing on the subsection name. When the subsection is collapsed only the subsection is displayed and
the questions are hidden. When the subsection is expanded all of the questions are displayed below
the subsection.
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The data for a question can be entered on the Question tab by clicking on the question on the menu
tree. The Question tab will show the question and provide areas for the answers to the question.
The format of the tab and allowable answers will depend on the question type that was specified
when the template was created. 

After the question has been answered the Report tab will show the text that will be entered into the
final report. This text may contain the text entered in the answer and/or text contained in the report
template for the specified answer.

At the bottom of the form there is a toolbar that can be used to move to the first
question, previous question, next question and last question.

After a question has been answered its icon on the Index will have a checkmark in it.
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2.7 Inserting Text Macros

On the Report Toolbar there is an Insert Macro button that can be used to insert previous-
ly created text macros into your answer.  When this button is pressed a drop down list of

macro sections will be displayed. And when the cursor is moved over a section a drop down list of
the text macros in that section will be displayed. To select a text macro to insert click on it in the
list. The text will then be inserted into your answer. By using previously created text macros you
can significantly reduce the amount of text entry required.
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2.8 Checking Unanswered Questions

The questions that have been answered are tracked and a list of unanswered questions can
be displayed at any time by clicking on the Check Unanswered Questions button on the

Report Toolbar or the Check menu item in the Edit menu. A list of the questions that have not been
answered will be displayed.
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2.9 Saving Report Data

The report data can be saved by clicking on the Save button on the Report toolbar or the Save
menu item on the File menu. 

The data can also be saved under a different name by clicking on the SaveAs button on the
Report toolbar or the SaveAs menu item in the File menu. The Report Name form will then

be displayed where you can enter a new name for the report.

2.10 Closing a Report

To close a report click on the Close button on the Report toolbar or select the Close menu
item on the File menu.

2.11 Deleting a Report

To delete a Report select the Delete menu item from the File menu or click on the Delete but-
ton on the toolbar. If the Delete menu item is not available make sure that there is a report
selected.
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2.12 Exporting Report Data

Report data can be exported to an exchange file that can then be transferred to a different project
or user. To export the report data select the Export Report Data menu item from the File menu.
Then specify the name of the file to save the report data in. If no report is currently selected, this
menu item will not be available.

2.13 Importing Report Data

Previously exported report data can be imported by selecting the Import Report Data menu item
from the File menu. The name of the file to be imported can then be entered.
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3.
Merging Report Data
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3.0 Merging Report Data

After the report data has been entered it can be merged with the report template to create the
final report. During the merging process the keywords in the report template are replaced by

the text associated with each of the answers to the questions. When the merging is complete a final
report will be created in Microsoft Word format. This report can then be edited in Word.

To merge a report either select the Merge button on the toolbar or the Merge menu item in the File
menu. The Merge Document form will be displayed.  

This form will let you change the report being merged and to specify the name of the merged
report. After either the Merge button has been clicked the progress of the merge operation will be
shown on the form.
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4.0 Text Macros

During the data entry process for reports some of the text being entered will be repetitive or best
selected from a list of text for different report areas; such as site descriptions, subsurface descrip-
tions, pavement design, foundation design etc. In order to reduce the time required to enter repeti-
tive text, text macros can be used.

Text macros are composed of lines of text that can be selected and inserted whenever there is a
description or information part of a question’s answer. To make it easier to select the text, the
macros are divided into sections.

To add a text macro click on the Macro button on the toolbar to display the Macro Editor
form. The text macros are divided into sections to make it easier to organize and select the

text. Sections are displayed on the left side of the form and the text for the selected section is dis-
played on the right side.



Sections

To add a new section click on the Add button on the toolbar and then enter the name
of the section.

To open an existing section click on the Open button on the toolbar. The text macros for that
section will then be displayed on the right part of the form.

To delete a section select the section and then click on the Delete button above the section.

Text Macros

To add a new text macro to a section, make sure that the section is open and then click
on the Add button on the toolbar. Then enter the text for the macro.

To change the text for a text macro select the text and either double click on the text or press
the Edit Text button on the toolbar.

To delete a text macro from a section, make sure that the section is open . Then select the text
to be deleted and then click on the Delete button on the toolbar.

Rapid Geotechnical Reporting User’s Guide Page  30

Editing Text Macros



5.
Preferences

Rapid Geotechnical Reporting User’s Guide Page  31



5.0 Preferences

The locations of the databases, projects, and templates can be specified using the program prefer-
ences. To change the program preferences select the Preferences menu item from the File menu. 

The following can be specified on the Preferences form:

Main Database Directory: This is the directory where the Access database containing the list of
projects and other information is stored.

Default Project Directory: This is the default directory where projects are stored.

Report Template Directory: This is the directory where the report templates are stored.
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6.0 Getting Help

Rapid Geotechnical Reporting uses the latest type of help system for Microsoft Windows called
HTML Help. This help system uses a similar style of display as Internet Explorer.

The Help System can be used to find information on-line rather than by using this manual. Both
sources will provide the same information, but are organized somewhat differently. Help will
appear in a separate window with its own menu bar and controls as shown below.

6.1 Displaying Help

There are several ways to access the Help System, these are:

• Press the Help button. To display the help contents at any time press the help button on the
Toolbar.

• Click a Help button in a form. For more information on using a particular form click the Help
button.

• Choose a command from the Help menu. The Help menu offers several options: 

- Contents displays the same Help Contents that appear when you press F1 with no com-
mands highlighted.

- Search displays the Search dialog box and a list of keywords you can use to find topics.

- About gives information about the program, including the 3-digit version number
required by technical support.

6.2 Using Help

You can move back and forth between topics or search through the entire help system for the topic
you want. Topics that are underlined can be displayed by clicking on them, and topics that have
dotted underlines can have their definition displayed by clicking on them.
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The tabs on the Help form are used for the following:

• Contents displays the complete Table of Contents of the Help System.

• Index is used to look for help topics listed by keyword.

-•Search can be used to search for a specific help topic by one or more keywords.

6.3 Getting Technical Support

GAEA offers a variety of services to help you with your questions and problems. You will be auto-
matically registered when you obtain an unlock code for the program. Free technical support to reg-
istered users for the first three months includes assistance in the use of the software and in getting
any bugs you may find in the software fixed.

To expedite support services, we prefer electronic communications, through email or the Internet.
These communications minimize the possibility for any mistakes, and allow us to better track your
request.  You can email technical support by selecting the Email Technical Support menu item from
the Help menu. This menu item will create an email message using your default email program. 

To connect to GAEA’s Internet site, select the GAEA's Web Site menu item from the Help menu.

Below are the various methods to contact technical support:

Service Contact Method
Web Site http:\\www.gaea.ca

E-mail support@gaea.ca

Phone (905) 666-7527

FAX (905) 666-3744

Mail GAEA Technologies Ltd.
87 Garden Street
Whitby, Ontario
Canada
L1N 9E7

After receiving your communication, GAEA will respond promptly with either the solution to the
problem or a schedule for solving the problem.
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6.4 Before Contacting GAEA

Before contacting technical support, we suggest you try the following to help us resolve your prob-
lem.

• Determine if the problem is specific to the project or report you are creating. Does it occur
with other reports or projects?

• Does the problem occur every time or intermittently?

• If you have another PC, does the problem occur on it?
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Printed in Canada

GAEA Technologies Ltd.
87 Garden Street
Whitby, Ontario

L1N 9E7
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